<!DOCTYPE html>
<html lang='en'>
<head>
<title>Second Round of Athletes Inducted in Bellingham Sports Hall of Fame | Bellingham Bulletin</title>
<meta charset='utf-8'>
<meta content='LocablePublisherNetwork.com' name='generator'>
<meta content='width=device-width, initial-scale=1' name='viewport'>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<script>window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"cc2c1fbc9a","applicationID":"18721","transactionName":"IQwNRUJXWQhdEBdZRxYKAF1VSxoXUA1P","queueTime":28,"applicationTime":912,"agent":""}</script>
<script>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</script>
<meta content='122882951100578' property='fb:app_id'>
<meta property="og:title" content="Second Round of Athletes Inducted in Bellingham Sports Hall of Fame | Bellingham Bulletin" /><meta name="description" content="Check out this list of the Bellingham athletes inducted into the Hall of Fame on Nov. 29, 2019, and their achievements (supplied by the Hall of Fame Committee)." /><meta property="og:description" content="Check out this list of the Bellingham athletes inducted into the Hall of Fame on Nov. 29, 2019, and their achievements (supplied by the Hall of Fame Committee)." /><meta name="keywords" content="Life+Leisure, Seniors, Today, Schools, Sports, Business, Community, Bellingham High School, Bellingham Athletic Department, Athletic Hall of Fame" /><meta name="ICMB" content="" /><link rel="canonical" href="http://www.bellinghambulletin.com/2019/11/29/291286/second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame" /><meta property="og:url" content="http://www.bellinghambulletin.com/2019/11/29/291286/second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame" /><meta content='article' property='og:type'>

<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="nGI+gyM0Hyddi9o/u+r2n4QSyUlnl6HlXj3xZ0zHLesnVc+F5ndwdQPaEsd9OhClxXCcSi8y3SZqH7b+E4T6bw==" />
<link rel="shortcut icon" type="image/x-icon" href="//cdn0.locable.com/assets/favicon-01526a03e76ee99373d957d3f48eb9c426ccc37e023838c62f4fd9cb76c11699.ico" />
<link rel="stylesheet" media="screen" href="//cdn0.locable.com/assets/application-e544c672c46236e9b7ef1aea29ee32fe0aaff0df79616580ce1596e7172a7d42.css" />
<link rel="stylesheet" media="print" href="//cdn3.locable.com/assets/print-a8ed28965cfc1e180c5fb2bf9a2246811c389e56a792ba2c42606d164408fef0.css" />
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
</script>
<script>
  ga('create', 'UA-44747537-1', 'auto');
  ga('send', 'pageview');
</script>
<script>
  ga('create', 'UA-16494411-5', 'auto', {'name': 'rollup'});
  ga('rollup.send', 'pageview');
</script>
<style>
  .custom-header, .custom-header a {color:  !important; }.custom-header {background-color: #bfeeff !important; }.custom-header {text-align: center !important; }#masthead .container {background-color: #bfeeff !important;}body.public, body.dco { background-color: #bfeeff;}#main-nav .navbar-nav .nav-link, .classic-nav .navbar-brand .navbar-text, #main-nav .navbar-toggler span {color:  !important;} #main-nav .navbar-toggler {border-color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {color:  !important;}#main-nav .navbar-nav .nav-link:hover, .classic-nav .navbar-brand:hover .navbar-text {background-color:  !important;}.public #main-nav .container, .dco #main-nav .container, .admin #main-nav, .admin #main-nav .container {background-color:  !important;}#main-nav .dropdown-item {color:  !important;}#main-nav .dropdown-item:hover {color:  !important;}#main-nav .dropdown-item:hover {background-color:  !important;}#main-nav .dropdown-menu {background-color:  !important;}#secondary-nav .navbar-nav .nav-link, #secondary-nav a {color: #000000 !important;}#secondary-nav .navbar-nav .nav-link:hover, #secondary-nav a:hover {color:  !important;}#secondary-nav .navbar-nav .nav-link:hover, #seconary-nav a:hover {background-color: #bfeeff !important;}#secondary-nav nav {background-color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {color:  !important;}#secondary-nav .navbar-nav .dropdown-menu .nav-link:hover {background-color:  !important;}#secondary-nav .dropdown-menu {background-color:  !important;}.col-menu li a, .simple-footer li a, #copyright p.text-muted a {color:  !important; }.col-menu li a:hover, .simple-footer li a:hover, #copyright p.text-muted a:hover {color:  !important; }#footer p, #footer h6, #copyright p {color:  !important; }.places #copyright, .places #footer, #copyright .container, #footer .container {background-color:  !important; }
</style>
<style>
  #secondary-nav .navbar {border-bottom: 5px solid #000; background-image: linear-gradient(to bottom, #FFF, #f2f2f2); box-shadow: inset 0 1px 0 rgba(255,255,255,0.15), 0 1px 5px rgba(0,0,0,0.075); background-repeat: repeat-x; background-color: #f8f8f8;}
  #secondary-nav .navbar {padding-left: 0; padding-right: 0;}
  /*#secondary-nav li a {font: normal normal 20px/20px 'BebasNeueRegular';}*/
  #secondary-nav li a {letter-spacing: -.5px; }
  #secondary-nav .navbar ul li a {border-right: dotted 1px #ddd;}
  #secondary-nav .navbar ul li:last-of-type {border-right: none;}
  #secondary-nav .row, #secondary-nav .col-sm-12 {padding-left: 0; padding-right: 0;}
  #secondary-nav li a {font-weight: bold; text-transform: uppercase; padding: 0 8px;}
</style>

<script async='' defer='defer' src='https://addevent.com/libs/atc/1.6.1/atc.min.js' type='text/javascript'></script>
</head>


<body class='classic-header public'>
<a class="sr-only" href="#content">Skip to main content</a>
<div class='fixed-top' data-toggle='affix'>
<section id='main-nav'>
<div class='container theme-shadow bg-white'>
<nav class='classic-nav navbar navbar-expand-lg navbar-light'>
<a class="navbar-brand" href="/"><span class='navbar-text fas fa-home' style='position:relative;top:2px'></span>
</a><button aria-controls='navbarContent' aria-expanded='false' aria-label='Toggle navigation' class='navbar-toggler' data-target='#navbarContent' data-toggle='collapse' type='button'>
<span class='fas fa-bars'></span>
</button>
<div class='collapse navbar-collapse' id='navbarContent'>
<ul class='navbar-nav mr-lg-auto' style='white-space: nowrap;'>
<li class='nav-item page-46553-nav'><a class="nav-link" href="/pages/local-experts">Local Experts/Spotlight</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-46552-nav'><a class="nav-link" href="/pages/archives">Archives</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-41378-nav'><a class="nav-link" href="/pages/contact">Contact Us</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-42055-nav'><a class="nav-link" href="/pages/submittals">Submittals</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<li class='nav-item page-40282-nav'><a class="nav-link" href="/pages/advertising">Advertising</a></li>
<!-- = link_to display_options['label'], nav_object(nav_element), target: ('_blank' unless !display_options['target_blank']), class: ("#{myclass} #{'d-none d-sm-block' unless !display_options['mobile']} #{nav_element}-nav") -->
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='d-lg-none'>
<li class='calendar-nav nav-item' data-toggle='calendar'>
<a class="nav-link" href="/calendar">Calendar
</a></li>
<li class='directory-nav nav-item' data-toggle='directory'>
<a class="nav-link" href="/businesses">Directory
</a></li>
<li class='category-90-nav nav-item' data-toggle='category-90'>
<a class="nav-link" href="/categories/in-print">In Print
</a></li>
<li class='category-776-nav nav-item' data-toggle='category-776'>
<a class="nav-link" href="/categories/business">Business
</a></li>
<li class='category-121-nav nav-item' data-toggle='category-121'>
<a class="nav-link" href="/categories/community">Community
</a></li>
<li class='category-777-nav nav-item' data-toggle='category-777'>
<a class="nav-link" href="/categories/schools">Schools
</a></li>
<li class='category-872-nav nav-item' data-toggle='category-872'>
<a class="nav-link" href="/categories/municipal">Municipal
</a></li>
<li class='category-873-nav nav-item' data-toggle='category-873'>
<a class="nav-link" href="/categories/seniors">Seniors
</a></li>
<li class='category-425-nav nav-item' data-toggle='category-425'>
<a class="nav-link" href="/categories/sports">Sports
</a></li>
<li class='category-1202-nav nav-item' data-toggle='category-1202'>
<a class="nav-link" href="/users/sign_in">County+State
</a></li>
<li class='category-124-nav nav-item' data-toggle='category-124'>
<a class="nav-link" href="/categories/life-leisure">Life+Leisure
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

<div class='dropdown-divider'></div>
</div>
<div class='d-lg-none'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

<div class='dropdown-divider'></div>
</div>
</ul>
<ul class='navbar-nav ml-lg-auto'>
<ul class='list-inline social-links' style='white-space: nowrap;'>
<li class='list-inline-item mr-2'>
<a target="_blank" class="facebook" href="https://www.facebook.com/bellinghambulletin/"><i class='fab fa-facebook fa-2x'></i>
</a></li>
</ul>

<form class="form-inline" action="/search" accept-charset="UTF-8" method="get"><input name="utf8" type="hidden" value="&#x2713;" />
<div class='input-group'>
<label class="sr-only" for="q">Search</label>
<input type="text" name="q" id="q" placeholder="Search Site" class="form-control" />
<span class='input-group-btn'>
<button class='btn btn-secondary btn-search'>
<span class='sr-only'>Search</span>
<span class='fas fa-search'></span>
</button>
</span>
</div>
</form>


</ul>
</div>
</nav>
</div>
</section>
</div>

<section id='alerts'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>

</div>
</div>
</section>
<header>
<section id='masthead'>
<div class='container theme-shadow bg-white'>
<div class='row'>
<div class='col-12'>
<h1 class='p-3'><a href="/"><img alt="Bellingham Bulletin" style="max-width: 100%;" src="//cdn2.locable.com/uploads/logo_image/file/367/bellingham-bulletin-logo.png" /></a></h1>
</div>
</div>
</div>
</section>

<div class='d-none d-lg-inline'>
<section id='secondary-nav'>
<div class='container theme-shadow bg-white'>
<div class='row py-1'>
<div class='col-sm-12'>
<nav class='navbar navbar-expand-lg navbar-light'>
<!-- %ul#theme-navigation-tabdrop-menu.navbar-nav.mr-auto -->
<ul class='navbar-nav mr-auto flex-wrap' style='white-space: nowrap;'>
<!-- %li.pull-left -->
<!-- = link_to :root do -->
<!-- - if current_site.homepage.present? -->
<!-- = current_site.homepage -->
<!-- - else -->
<!-- %span.fa.fa-home{style: 'font-size:14px;position:relative;top:-1px'} -->
<li class='calendar-nav nav-item' data-toggle='calendar'>
<a class="nav-link" href="/calendar">Calendar
</a></li>
<li class='directory-nav nav-item' data-toggle='directory'>
<a class="nav-link" href="/businesses">Directory
</a></li>
<li class='category-90-nav nav-item' data-toggle='category-90'>
<a class="nav-link" href="/categories/in-print">In Print
</a></li>
<li class='category-776-nav nav-item' data-toggle='category-776'>
<a class="nav-link" href="/categories/business">Business
</a></li>
<li class='category-121-nav nav-item' data-toggle='category-121'>
<a class="nav-link" href="/categories/community">Community
</a></li>
<li class='category-777-nav nav-item' data-toggle='category-777'>
<a class="nav-link" href="/categories/schools">Schools
</a></li>
<li class='category-872-nav nav-item' data-toggle='category-872'>
<a class="nav-link" href="/categories/municipal">Municipal
</a></li>
<li class='category-873-nav nav-item' data-toggle='category-873'>
<a class="nav-link" href="/categories/seniors">Seniors
</a></li>
<li class='category-425-nav nav-item' data-toggle='category-425'>
<a class="nav-link" href="/categories/sports">Sports
</a></li>
<li class='category-1202-nav nav-item' data-toggle='category-1202'>
<a class="nav-link" href="/2019/11/29/291232/residents-business-people-experience-taste-of-bellingham-">County+State
</a></li>
<li class='category-124-nav nav-item' data-toggle='category-124'>
<a class="nav-link" href="/categories/life-leisure">Life+Leisure
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

</div>
<section id='pushdown'>
<div class='container theme-shadow bg-white'>
<div class='d-flex justify-content-center'>
<div class='py-3'><broadstreet-zone
        zone-id='pushdown'
        keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='pushdown'
                  keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin',
                  count='1'></broadstreet-zone></div>
</div>
</div>
</section>
</header>
<div class='container theme-shadow bg-white' id='content'>
<div class='row'>
<div class='col-12 col-lg-8'>
<section id='admin-buttons'>
<div class='container'>
<div class='row'>
<div class='col-12'>
<div class='btn-group btn-group-sm'>
</div>
</div>
</div>
<div class='row py-2'>
<div class='col-12'>
</div>
</div>
</div>
</section>
<article>
<div class='container'>
<div class=''>
<div class='row py-3'>
<div class='col-12'>
<h1 class='py-0'>
<div class='text-capitalize'>Second Round of Athletes Inducted in Bellingham Sports Hall of Fame</div>
</h1>
<span class='small text-muted'>
Nov 29, 2019 06:00AM
&#x25CF By Pamela Johnson
</span>
</div>
</div>
<div class='d-flex justify-content-center'>
<div class='py-3 broadstreet'>
<broadstreet-zone
        zone-id='sponsored'
        keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='sponsored'
                  keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin',
                  count='1'></broadstreet-zone>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='clearfix images-contain images-thumbnails'>
Following is a list of the Bellingham athletes inducted into the Hall of Fame on Nov. 29, 2019, and their achievements. (These biographies were supplied to the <i>Bulletin</i> by the Hall of Fame Committee, who are responsible for their content.)<br><br><h3>1993 football team</h3>The Blackhawks recorded a Bellingham first that fall 26 years ago: they were the first football team from the school to earn a Super Bowl berth. They didn’t squander the opportunity, with a 41-18 victory over Marian High of Framingham in the Division 6A contest.<br>The Hawks were the first of coach Dale Caparaso’s four teams to go to a Super Bowl – and win it.<br><div><br></div><div>The 1993 team was a splendid combination of a high-octane offense and a stingy defense. They scored an average of over 30 points per game and allowed just over 10 points per game. In seven of their 11 games they allowed just a touchdown or less.</div><div><br></div><div>A trio of seniors--quarterback Greg Smith and halfbacks Jeff LaRose and Mark Goyer--and junior fullback Jeremy Bernard gave the Hawks a lot of offensive weapons to throw at the opposition. Their job was made all the easier by senior wide receiver Andy Dubovsky, junior tight end Russ Watson, senior guards Adam Bernard and J.R. Edick, sophomore center Brian Cronin, and senior tackle Doug McCann and junior tackle Joey Grassi up front.</div><div><br></div><div>A lot of the names were the same on defense with the addition of senior Sean Murphy at safety and junior Mike Tabarini, who handled the place-kicking duties, also contributing at defensive end and outside linebacker.</div><br><h3>George Anderson</h3>After graduating from Boston University in 1965, Anderson arrived at BHS as a Physical Education teacher, just one of the many hats he would wear before retiring 33 years later in 1998.<br><div><br></div><div>He would resurrect the football program, serving as the head coach from 1965 through 1969. “We were starting from scratch,” said Anderson. “Ordering equipment, even showing the players how to put their uniforms on. Most of them had no sense of strategy.”</div>Anderson also coached track. “The track program was in place, but there was very little continuity,” he said. “We were competitive at times, but we were way behind a lot of other schools.”<br><div><br></div><div>His tenure as a classroom teacher was an enjoyable one. “It was a good experience,” said Anderson. “The kids were always receptive. It was a lot of work, but it was certainly fulfilling.”</div>Anderson served as the director of athletics from 1972 until 1996. “The 1970s and 1980s were a period of huge growth in our athletic program, particularly in our girls’ teams,” he said.  “We brought in coaches who could relate to the kids. We started to win and things just came to fruition.”<br><div><br></div><div>During the final three years of his stay at the school he assumed the role of vice principal. “It was like being the sheriff in town,” Anderson said. “At times it wasn’t a lot of fun; you were dealing with a certain element, and the parents had changed a lot.”</div><div><br></div><div>George and Jacquie Anderson spent many hours attending BHS athletic events over the years. “There were times I think I spent more time with Bellingham kids than I did with my own,” he said with a chuckle. “Having the football field named after me and now being elected to the hall of fame is overwhelming.”</div><br><h3>Jim Bonollo</h3>A 1963 graduate of BHS, Bonollo was a member of the cross country, basketball and baseball teams for the Blackhawks. They were the only boys’ teams offered at the time. “Frank Flynn was my coach in all three sports,” said Bonollo.<div><br></div><div>Bellingham took fourth place in the Worcester Memorial Cross Country Meet his senior year. “That was a big deal at the time,” he said. <br></div><div><br></div><div>In the days before the 3-point shot, Bonollo, a guard, scored 1,498 points in his varsity basketball career. “I held the record for career points for three years until my cousin Glenn Garipey came along and broke it with 2,040,” he said.</div><div><br></div><div>Bonollo was a catcher for the baseball team. “We were also-rans in baseball; we didn’t have a lot of team success,” he said.</div><div><br></div>He went to nearby Dean Junior College, where he played soccer, basketball and baseball. He was a Junior College All-American in basketball and the school’s Athlete of the Year as a senior.<br><div><br></div><div>Bonollo went to MacMurray College in Illinois, where he played baseball. He graduated in 1968.</div><div><br></div><div>He met his wife, Susan, at MacMurray, and they returned to Bellingham to teach. She taught science, and he taught physical education. They retired in 2001 and moved to Arizona.</div>Bonollo was a successful basketball and baseball coach at BHS. His Blackhawks won one Tri-Valley League title in basketball and five in baseball.<br><br><h3>Rich Boucher</h3><div>This 1989 BHS graduate wasn’t physically imposing, but he was a veritable giant when he stepped onto the mound for the Blackhawks.</div><div><br></div>Boucher still holds the career record for victories with a three-year varsity mark of 21-9.   Using pin-point control and an outstanding curveball, he rang up an astounding 284 strikeouts in 219 career innings. He also allowed just 53 career walks and had 28 complete games.<br><div><br></div><div>Those statistics earned him a pair of Tri-Valley League MVP honors and three straight selections as a first-team All-TVL.</div><div><br></div><div>Boucher pitched for the Milford Legion and compiled a 23-2 record for the team.</div>A four-year varsity pitcher at Brown University, Boucher won 12 games for the Bears, despite battling injury problems.<br><div><br></div><div>He earned a psychology degree at Brown and is currently a system analyst for Medtronic Computers in Mansfield.</div><br><h3>Roger Canestrari, Sr.</h3><div>Canestrari’s graduation from Bellingham High School in 1954 didn’t end his association with the school, not by a longshot.</div><div><br></div>He served as a classroom teacher at BHS, basketball and baseball coach, vice principal and principal. He entered the school in 1951 as a freshman and left in 1997 when he retired.<br><div>During his tenure as a student, Canestrari was an outstanding athlete. In fact, he holds the distinction of being the first Bellingham athlete to earn a full athletic scholarship when he was awarded one to play basketball at Providence College. <br></div><div><br></div><div>As a senior at BHS he averaged 28 points and 12 rebounds per game. He scored 511 points during his final year of high school basketball and was named the MVP of the Assumption College Tournament.</div><div><br></div>In baseball, Canestrari batted .520 in his final year of high school baseball. He also played for an outstanding Milford Legion team, one that lost in the national finals at Yakima, Washington.<br><div>At Providence, he played under legendary coach Joe Mullaney and was a teammate of hall of famer Lenny Wilkins.</div><div><br></div>After college graduation, Canestrari jumped into coaching with tremendous success. He won Tri-Valley League titles in both basketball and baseball.<br><br><h3>Lauren Clancy</h3><div>This 1999 BHS graduate was a ferocious competitor in athletics, particularly in basketball. She holds the amazing distinction of recording over 1,000 points (1,527) and 1,000 rebounds (1,315) during her career with the Blackhawks. Her points scored totals rank second among all school athletes, regardless of gender.</div><div><br></div><div>Clancy also played some volleyball, softball and track. Those sports often took a backseat to her AAU basketball.</div><div><br></div><div>As an undergraduate, she was a member of several teams that advanced to the national AAU championship. Her play earned her a full basketball scholarship to American International College in Springfield, where she was a four-year starter for the Yellow Jackets.</div><div><br></div>During her college career Clancy helped AIC win the NE-10 regular season title, the league playoff crown and a trip to the Elite Eight as a junior.<br><div><br></div><div>Since graduation from college, she has caught the coaching bug, serving as an assistant coach at Westfield State University and BHS at one point. She is expected to return to her high school alma mater this winter to again serve as an assistant coach.</div><br><h3>Ralph Moore</h3>Ralph Moore graduated from Bellingham High School in 1981 as the most accomplished male runner in the history of the school. To this day, he still holds that distinction. In cross country, Moore held course records throughout the TVL and as a junior he placed first in the league meet and third in the state.<br><div><br></div><div>In winter track, he ran a 4:20 mile and a 9:22 two-mile, a school record that still stands.  He won the EMass title at BU in the mile and was fourth among all New England runners in the two-mile in a race held at Harvard.</div><div><br></div><div>In spring track, Moore placed third as a senior in the New Englands in New Hampshire with a school-record of 4:18, a mark that still stands.  He won the league title in both the mile and two-mile as a sophomore through senior year. He went to Northeastern University on a full athletic scholarship. He was MVP for three years in a row in cross country for the Huskies. Moore was also All-New England in track &amp; field.<br></div><div><br></div><div>Following graduation in 1986 with a degree in economics, he ran professionally for Adidas for two years and one year for New Balance.</div><div><br></div><div>Ralph and Angela Moore have been married 14 years and have a son, Sam (10). Moore has worked for the Federal Reserve Bank system for 33 years.<br></div><div><br></div><div>“Just to be remembered like this after so many years is amazing,” said Moore of his induction. “George Anderson was the athletic director, and Paul Cournoyer was my coach. Those two men had a lot to do with any success I had. I will never forget them.”</div><br><h3>Jackie Pizzi Prescott</h3><div>Prescott graduated from BHS in 1996 with a field hockey resume bordering on the unbelievable.  She was the starting goalie for the Blackhawks all four years in high school and racked up an astounding 49 shutouts during that time span. Obviously, those kinds of numbers generated a ton of honors. She was selected to play in the Massachusetts vs. Connecticut All-Star Game and was named a Best of 60 All-Star at the state level. Prescott was also named a <i>Boston Herald</i> All-Scholastic in 1995.<br></div><div><br></div><div>In addition to field hockey, she played a couple of years of basketball and also softball for the Blackhawks. But it was her superlative play in field hockey that earned her a partial scholarship to the University of Rhode Island. “Division I field hockey was very intense,” she said.<br></div><div><br></div><div>She is married to Tay Prescott, who graduated from BHS and played basketball at URI. The couple have two sons: Cooper (7) and Carter (4). Prescott is a senior trust officer and vice president for Bank of America in Providence.<br></div><br><h3>Melissa Ranieri-Bertonazzi</h3>Melissa Ranieri played both softball and field hockey for the Blackhawks. Still, the 1999 grad was best known for her timely field hockey heroics. She was on the 1996 Division 2 state championship team, scoring the tying and winning goal in a 4-3 victory.  She helped lead the Blackhawks to a berth in the Division 2 state finals her senior year, where they were defeated 2-1 in overtime. In five postseason games that year, Melissa netted ten goals on top of 28 regular-season goals.<br><div><br></div><div>Following the 1998 season, Bertonazzi was named a first-team all-star by the<i> Boston Globe</i>, the <i>Boston Herald</i>, and the <i>Milford News</i>. She went on to play four years of field hockey at Merrimack College, graduating in 2003.</div><br><h3>Mike Reed, Jr.</h3>Reed graduated from BHS in 1984 after a standout career in basketball and baseball. He was a three-year letter winner during the winter months and a four-year letter winner and three-year starter in the diamond game. A two-time Tri-Valley League All-Star in baseball, he earned league MVP honors as a senior. He was also named an all-star two years running for the <i>Milford News</i> and the <i>Woonsocket Call</i> as well as being selected as an Eastern Mass All-Star as a senior.<br><div><br></div><div>Reed helped lead the Blackhawks to the state semifinals in baseball his senior year.</div>He earned all-star honors as a senior in basketball and served as a captain in both basketball and baseball that year.<br><div><br></div><div>Reed played two years for the Milford Legion and one year for the Milford Town Team.</div>An outstanding student, Reed was the president of the National Honor Society and matriculated at Princeton University. He played baseball all four years for the Tigers.<br>He is currently lead council for All State and Encompass Insurance.<br><br><h3>Brian <b><i></i></b>Sherlock</h3>A 1981 graduate of BHS, Sherlock was a sophomore when the school started its hockey program. The Blackhawks were successful from the get-go, chalking up a 41-12-5 record with him in goal. He was credited with five shutouts and a 1.81 goals-against-average during that time span. Despite its being a new program, Sherlock and the Hawks played in the Boston Garden during his junior year, losing in the EMass semifinals.He also played baseball for BHS. He was a catcher and sometime pitcher.<br><div><br></div><div>Sherlock played one year of varsity hockey at what is currently called UMass-Dartmouth.</div>Sherlock returned to coach at his alma mater. Beginning in 1991, he served as an assistant for four years and took the head coaching reins for 16 more.<br><div><br></div><div>“Being elected to the hall of fame is a huge honor,” said Sherlock. “I’m humbled by it. It’s hard to believe.”</div><div><br></div><div>He is a purchasing manager for Alpha Graphics with offices in New Bedford and Providence.</div>Brian and Mary Sherlock have been married 29 years and are the parents of three daughters: <b></b>Kathryn (26), Alyson (25), and Nicole (23).<br>
</div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_native_toolbox'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<span class='fas fa-tags' style='margin-right: 2px'></span>
<a style="color: #555" href="/categories/life-leisure">Life+Leisure</a>, <a style="color: #555" href="/categories/seniors">Seniors</a>, <a style="color: #555" href="/categories/today">Today</a>, <a style="color: #555" href="/categories/schools">Schools</a>, <a style="color: #555" href="/categories/sports">Sports</a>, <a style="color: #555" href="/categories/business">Business</a>, <a style="color: #555" href="/categories/community">Community</a>
<a style="color: #555" href="/article_tags/bellingham-high-school">bellingham high school</a>
<a style="color: #555" href="/article_tags/bellingham-athletic-department">Bellingham athletic department</a>
<a style="color: #555" href="/article_tags/athletic-hall-of-fame">Athletic Hall of Fame</a>

</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='addthis_recommended_horizontal'></div>
</div>
</div>
<div class='row py-3'>
<div class='col-12'>
<div class='fb-comments' data-href='http://www.bellinghambulletin.com/2019/11/29/291286/second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame' data-width='100%'></div>
</div>
</div>
</div>
</div>
</article>
<script>
  var addthis_share = {
     url: "http://www.bellinghambulletin.com/2019/11/29/291286/second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame",
     title: "Second Round of Athletes Inducted in Bellingham Sports Hall of Fame",
     description: "Check out this list of the Bellingham athletes inducted into the Hall of Fame on Nov. 29, 2019, and their achievements (supplied by the Hall of Fame Committee).",
     media: ""
  }
</script>

</div>
<div class='col-12 col-lg-4'>

<div class='div' style='width: 300px; margin: auto;'>
<div id='calendar-widget'>
<div class='undecorate'>
<div class='my-3'>
<h5 class='px-3 py-2 custom-header'>Upcoming Events Near You</h5>
<a class="undecorate" href="/events/159310/dj-becky"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
29
</strong>
</div>
<div class='media-body ml-2'>
<h6>DJ Becky</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
8:00pm
&#183;
Bellingham VFW Post 7272
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/157642/memory-cafe"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
30
</strong>
</div>
<div class='media-body ml-2'>
<h6>Memory Cafe</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
10:00am
&#183;
Bellingham Senior Center
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/159313/karaoke"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
30
</strong>
</div>
<div class='media-body ml-2'>
<h6>Karaoke</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
8:00pm
&#183;
Bellingham VFW Post 7272
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/176478/small-business-saturday-celebration"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
30
</strong>
</div>
<div class='media-body ml-2'>
<h6>Small Business Saturday Celebration </h6>
<div class='text-muted small' style='margin-bottom: 2px'>
12:00pm
&#183;
Boutique Stellarum
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/177025/inaugural-inter-school-tournament-and-open-house"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
30
</strong>
</div>
<div class='media-body ml-2'>
<h6>Inaugural Inter-School Tournament and Open House</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
10:00am
&#183;
Nick Cerio's Kenpo
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/177191/svaroopa-yoga-with-suzanne"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
30
</strong>
</div>
<div class='media-body ml-2'>
<h6>Svaroopa® Yoga with Suzanne</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
9:45am
&#183;
Time for You Yoga
</div>
</div>
</div>
</div>
</div>
</div>
</a><a class="undecorate" href="/events/159319/steak-shoot"><div class='card border-0 m-1'>
<div class='card-body p-1'>
<div class='card-text p-1'>
<div class='media'>
<div class='span fa-stack fa-lg'>
<i class='far fa-calendar fa-stack-2x'></i>
<strong class='fa-stack-1x calendar-text'>
1
</strong>
</div>
<div class='media-body ml-2'>
<h6>Steak Shoot</h6>
<div class='text-muted small' style='margin-bottom: 2px'>
4:30pm
&#183;
Bellingham VFW Post 7272
</div>
</div>
</div>
</div>
</div>
</div>
</a>
<div class='d-flex justify-content-center pb-3'>
<a class="btn btn-light" href="/calendar"><div class='fas fa-calendar-alt'></div>
View All
</a><a class="btn btn-light rounded-0" href="/events/new"><div class='fas fa-plus-circle'></div>
Add Your Event
</a></div>
</div>
</div>
</div>

<div class='images-sidebar my-3 clearfix'>
<div class="image-align-left"><a href="https://agents.allstate.com/jim-richardson-bellingham-ma.html"><img alt="" src="//cdn3.locable.com/uploads/resource/file/635884/fill/0x0/RichardsonAllstate9-19.gif?timestamp=1567621750"></a></div><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-with-caption image-medium"><div class="image-medium image-align-left"><a href="http://www.MassRenewables.net"><img alt="" src="//cdn2.locable.com/uploads/resource/file/509197/fill/300x0/web_ad.jpg?timestamp=1548865673"></a></div><p>&nbsp;</p></div><p>&nbsp;</p><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<div class="image-medium image-align-left"><a href="http://www.BellinghamStuff.com"><img alt="" src="//cdn2.locable.com/uploads/resource/file/635900/fill/300x0/WebSidebarAd.jpg?timestamp=1567622829"></a></div><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p><p>&nbsp;</p>
</div>
<div class='images-sidebar my-3 clearfix'>
<iframe src="//www.facebook.com/plugins/likebox.php?href=https%3A%2F%2Fwww.facebook.com%2Fpages%2FBellingham-Bulletin%2F61738967050&amp;width=300&amp;height=590&amp;colorscheme=light&amp;show_faces=true&amp;header=true&amp;stream=true&amp;show_border=true&amp;appId=122882951100578" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:590px;" allowTransparency="true"></iframe>
</div>
<div class='images-sidebar my-3 clearfix'>
<h5 class='custom-header py-2 px-3'>Seasonal Widget</h5>
<script id="ff-widget-script" type="text/javascript" charset="utf-8">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'http://editorwidgets.familyfeatures.com/dist/ff-contentwidget.min.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
    window.FFWidget_client_article_url = location.protocol + '//' + location.host + location.pathname;
  })();
</script>
<div class="ff_widget-container" data-layout="one" data-themecolors="#cccccc,#ffffff,#e8e8e8,#e0e0e0,#000000,#000000" data-moduleid="2" data-uid="food-99999-31378" data-categoryid="1" data-style="border-color:#cccccc;"><span class="ff-placeholder">Loading Family Features Content Widget</span></div>
<div class="ff_display-article-full-content" data-uid="food-99999-31378"><span class="ff-placeholder">Loading Family Features Article</span></div>
</div>
<div class='images-sidebar my-3 clearfix'>
<script type="text/javascript" src="http://feeds.statepoint.net/scripts/ArticleWidget.js?wfid=400"></script>
</div>

</div>

</div>
</div>
</div>
<footer>
<section id='community-sponsor-footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>
</div>
</div>
</div>
</section>

<section id='footer-embed'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-sm-12'>

</div>
</div>
</div>
</section>
<section id='footer'>
<div class='container theme-shadow bg-white'>
<div class='row py-3'>
<div class='col-12'>
<nav class='navbar navbar-expand-lg'>
<ul class='navbar-nav mr-auto simple-footer flex-wrap' style='white-space: nowrap;'>
<li class='calendar-nav d-lg-inline d-none nav-item' data-toggle='calendar'>
<a class="nav-link" href="/calendar">Calendar
</a></li>
<li class='d-lg-inline d-none directory-nav nav-item' data-toggle='directory'>
<a class="nav-link" href="/businesses">Directory
</a></li>
<li class='category-90-nav d-lg-inline d-none nav-item' data-toggle='category-90'>
<a class="nav-link" href="/categories/in-print">In Print
</a></li>
<li class='category-776-nav d-lg-inline d-none nav-item' data-toggle='category-776'>
<a class="nav-link" href="/categories/business">Business
</a></li>
<li class='category-121-nav d-lg-inline d-none nav-item' data-toggle='category-121'>
<a class="nav-link" href="/categories/community">Community
</a></li>
<li class='category-777-nav d-lg-inline d-none nav-item' data-toggle='category-777'>
<a class="nav-link" href="/categories/schools">Schools
</a></li>
<li class='category-872-nav d-lg-inline d-none nav-item' data-toggle='category-872'>
<a class="nav-link" href="/categories/municipal">Municipal
</a></li>
<li class='category-873-nav d-lg-inline d-none nav-item' data-toggle='category-873'>
<a class="nav-link" href="/categories/seniors">Seniors
</a></li>
<li class='category-425-nav d-lg-inline d-none nav-item' data-toggle='category-425'>
<a class="nav-link" href="/categories/sports">Sports
</a></li>
<li class='category-1202-nav d-lg-inline d-none nav-item' data-toggle='category-1202'>
<a class="nav-link" href="/categories/sports">County+State
</a></li>
<li class='category-124-nav d-lg-inline d-none nav-item' data-toggle='category-124'>
<a class="nav-link" href="/categories/life-leisure">Life+Leisure
</a></li>
<div class='dropdown-divider d-inline d-lg-none'></div>

</ul>
</nav>
</div>
</div>
</div>
</section>

<section id='copyright'>
<div class='container theme-shadow'>
<div class='row pt-3' style='padding-bottom: 50px;'>
<div class='col-12'>
<p class='text-muted small p-0 m-0'>
<span class='far fa-copyright'></span>
2019 | Powered by <a target="_blank" class="text-muted" href="//www.locable.com">Locable</a>
|
<a class="text-muted" href="//national.locable.com/pages/terms-of-use">Terms of Service</a>
</p>
</div>
</div>
</div>
</section>

<section class='fixed-bottom' id='admin-bar'>
<nav>
<div class='d-none d-lg-flex'>
<div class='container'>
<ul class='nav justify-content-center px-3 mx-auto'>
<!-- = link_to image_tag('locable-l-icon.png', alt: 'Locable'), :root, class: 'navbar-brand hidden-xs' -->
<li class='nav-item'><a class="nav-link px--lg-2 py-lg-0 submit-event-link" href="/events/new">Submit an Event</a></li>
<li class='nav-item'><a class="nav-link px-lg-2 py-lg-0 create-listing-link" href="/places">List Your Business</a></li>
<li class='nav-item'>
<a class="nav-link px-lg-2 py-lg-0" href="/users/sign_in">Login/Join
</a></li>

</ul>
</div>
</div>
</nav>
</section>
</footer>
<div class='modal fade' id='welcome-modal' role='dialog' tabindex='-1'>
<div class='modal-dialog modal-lg' role='document'>
<div class='modal-content'></div>
</div>
</div>

<broadstreet-zone
        zone-id='popout'
        keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin'></broadstreet-zone><broadstreet-zone
                  alt-zone-id='popout'
                  keywords='articles, article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame, bellingham-bulletin',
                  count='1'></broadstreet-zone>
<script src="//cdn3.locable.com/assets/application-8d6ebb88cb29b22bf1d9ec353e3219318dbce89724b980494c4a3d2a098ebaaf.js"></script>
<div id='fb-root'></div>
<script>
  (function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.5&appId=122882951100578";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));
</script>

<script>
  window.s3DirectPostUrl = "https://locable-processing.s3.amazonaws.com/";
  window.s3DirectPostFields = {"AWSAccessKeyId":"AKIAJ6MRUF66HJSZBEVA","key":"uploads/25f63f39-7aa0-4dff-80eb-c7d27de370e5/${filename}","policy":"eyJleHBpcmF0aW9uIjoiMjAxOS0xMS0yOVQxOTozMjozMloiLCJjb25kaXRpb25zIjpbeyJidWNrZXQiOiJsb2NhYmxlLXByb2Nlc3NpbmcifSxbInN0YXJ0cy13aXRoIiwiJGtleSIsInVwbG9hZHMvMjVmNjNmMzktN2FhMC00ZGZmLTgwZWItYzdkMjdkZTM3MGU1LyJdLHsic3VjY2Vzc19hY3Rpb25fc3RhdHVzIjoiMjAxIn0seyJhY2wiOiJwdWJsaWMtcmVhZCJ9XX0=","signature":"4R5jziLiPTaSgCw7ru7JQ9GPN6c=","success_action_status":"201","acl":"public-read"};
</script>


<script src="https://static.locablepublishernetwork.com/init-2.min.js" async="async"></script>
<script>
  window.broadstreet = window.broadstreet || { run: [] };
  window.broadstreet.run.push(function() {
    broadstreet.watch( {
      "autoAttach": {},
      "autoAttachAndWatch": {},
      "keywords": ["articles", "article_second-round-of-athletes-inducted-in-bellingham-sports-hall-of-fame", "bellingham-bulletin"],
      "networkId": "2267",
      "selector": 'broadstreet-zone',
      "softKeywords": true,
      "uriKeywords": false,
      "useZoneAliases": true,
      "useAltZone": 768,
      "domain": "sponsors.locablepublishernetwork.com"
    });
  });
</script>

<script src="https://cdnjs.cloudflare.com/ajax/libs/jQuery.print/1.5.1/jQuery.print.min.js"></script>


<script src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-52a6071c0ad9d295" async="async"></script>

<script src='https://code.jquery.com/jquery-migrate-3.0.1.js' type='text/javascript'></script>
</body>
</html>
